Zenwalk Gnome 5.2 alpha

Official news from the Zenwalk crew
McLovin
Regular Zenwalker
Regular Zenwalker
Posts: 12
Joined: Tue Jul 08, 2008 4:02 pm
Contact:

Re: Zenwalk Gnome 5.2 alpha

Post by McLovin » Tue Aug 05, 2008 4:44 pm

Yes, i have installed over the previouse Zen install, and have just this one now, and all is working, however, gnome does not have a built in compositing, so that may be where the issue is coming from. try taking that line of code out and see if it helps.

gapan

Re: Zenwalk Gnome 5.2 alpha

Post by gapan » Tue Aug 05, 2008 6:06 pm

The compositor is in fact part of gnome. It is included in metacity and is really great in my opinion. I think I'm going to keep it on by default and provide a menu option to switch it on/off whenever you want. To turn it off just do

Code: Select all

gconftool-2 --type boolean --set /apps/metacity/general/compositing_manager false

from the console and

Code: Select all

gconftool-2 --type boolean --set /apps/metacity/general/compositing_manager true

to turn it back on again.

Did you try Alt+tab to switch apps with compositor on? If you didn't, try it now. ;)

Or you can use xterm as a terminal instead. It always works. ;D

User avatar
C>Lemon
Senior Zenwalker
Senior Zenwalker
Posts: 257
Joined: Sun Apr 06, 2008 12:02 am
Location: Ireland by birth, Munster by Grace of Linus Torvald, etc.
Contact:

Re: Zenwalk Gnome 5.2 alpha

Post by C>Lemon » Tue Aug 05, 2008 7:17 pm

gapan wrote:Or you can use xterm as a terminal instead. It always works. ;D


That's what I had to do all those moons ago (about five or six, actually) when the default Terminal crashed X on my machine. And just so you know, changing the Default Depth to 16 made it unusable! ???

Anyway, I like the idea, although I think I would be on the side of KDE in the Battle of WMs; GNOME seems to be really unfriendly to all but the people who let it do its own thing...

At last we have other options besides XFCE for potential users to download! I think this will really give the ratings a boost.
Last edited by C>Lemon on Thu Aug 07, 2008 2:32 pm, edited 1 time in total.
Zenwalk - plugged mercilessly wherever Linux is discussed.

Zenwalk Support - WE PREVAIL

Humble Head of Newsletter.

Recommend stuff for the Newsletter!

See it here!

Thanks to fanch for the avatar!

My Specs.

User avatar
laprjns
Community Packager
Community Packager
Posts: 348
Joined: Fri Mar 10, 2006 3:52 am
Contact:

Re: Zenwalk Gnome 5.2 alpha

Post by laprjns » Thu Aug 07, 2008 10:24 am

toothandnail wrote:
gapan wrote:That seems to be working. I had to fiddle a bit to get X working under VirtualBox - even after I installed Til's patched drivers, I had to edit /etc/X11/xorg.conf - screen was oversized until I removed the highest resolution. Once I'd set 1024xx768 it worked.
paul.
Hey all,
I tried installing in VirtualBox last night and got a blank screen when it started. What fixes to xorg do I have to do?
BTW - I never got this problem with Zenwalk Standard running in VirtualBox. Alway boots into X for me.
"You are the proud owner of the very first purchased official Zenwalk CD with official Zenwalk artwork!"  Axxium March 10, 2006

gapan

Re: Zenwalk Gnome 5.2 alpha

Post by gapan » Thu Aug 07, 2008 10:30 pm

I was going to announce 5.2 beta today, but I decided I'll try to fix the virtualbox problem and another minor issue I've found and I'll probably upload 5.2 beta tomorrow.

User avatar
laprjns
Community Packager
Community Packager
Posts: 348
Joined: Fri Mar 10, 2006 3:52 am
Contact:

Re: Zenwalk Gnome 5.2 alpha

Post by laprjns » Fri Aug 08, 2008 12:37 pm

toothandnail wrote:You will need to replace the existing vesa drivers with the ones that Til patched. Find the thread here:
viewtopic.php?f=24&t=17077&st=0&sk=t&sd=a&start=15
and find the drivers here:
http://users.zenwalk.org/user-accounts/tilderb/tmp/
What I did was start the VM, when it tried to start X, used ^F2 to get to a virtual console, logged in as root, used netpkg to install links, then used links to download the two driver files from the URL above. I then renamed the original drivers in /usr/lib/xorg/modules/drivers/ and copied Tils patched ones in.
paul.

Thanks, Paul but I couldn't get it to work on my vbox install. When I boot it, it gets to the point where it's starting x but all I get is a black screen with the cursor in the top left corner. From there I can't get into a virtual console and the curses does not respond to any keyboard actions. I did tried several times to re-installed but I got the same results. On the first boot configuration after my last install I did notice that I was never asked about video configuration, just sound card, root password, user creation etc.

Rich
"You are the proud owner of the very first purchased official Zenwalk CD with official Zenwalk artwork!"  Axxium March 10, 2006

gapan

Re: Zenwalk Gnome 5.2 alpha

Post by gapan » Fri Aug 08, 2008 12:44 pm

Please wait a few hours. Beta is being uploaded right now, but it's going to take a few more hours. It works under virtualbox, albeit with a 1280x1024 default resolution.

gapan

Re: Zenwalk Gnome 5.2 alpha

Post by gapan » Fri Aug 08, 2008 6:11 pm

Zenwalk Gnome 5.2 beta has been announced: viewtopic.php?f=2&t=18011

Please continue discussion there.

Thanks! :)

Locked

Who is online

Users browsing this forum: Google [Bot] and 2 guests