Zenwalk 7.0 ALPHA ISO is available for testing !

Official news from the Zenwalk crew
User avatar
stillborn
Global Moderator
Global Moderator
Posts: 1311
Joined: Tue Mar 06, 2007 12:34 pm
Location: Suomi Finland
Contact:

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by stillborn » Wed Dec 22, 2010 2:50 pm

gmg wrote:for /dev/shm

probably this work

edit /etc/fstab

and added this line in:

tmpfs /dev/shm tmpfs defaults 0 0

and reboot

For JP, I THINK THIS LINE IS NEEDED IN THE '/etc/fstab' ;)

In Zenwalk 7.0 alpha

Code: Select all

root[stillborn]# l -la /dev/shm/
total 0
drwxr-xr-x  2 root root   40 Dec 22 11:00 .
drwxr-xr-x 14 root root 2980 Dec 22 13:34 ..


In Zenwalk 6.4

Code: Select all

root[stillborn]# l -la /dev/shm/
total 0
drwxrwxrwx  2 root root   40 Dec 22 11:00 .
drwxr-xr-x 14 root root 2980 Dec 22 13:34 ..

added line tmpfs /dev/shm tmpfs defaults 0 0 in fstab and after reboot
on Zenwalk 7.0alpha

Code: Select all

stillborn[~]$ l -la /dev/shm/
total 0
drwxrwxrwt  2 root root   40 Dec 22 16:38 .
drwxr-xr-x 14 root root 2980 Dec 22 16:36 ..

and for example chromiums work with that :)
and that is needed too for people who use fglrx driver.

User avatar
gmg
Global Moderator
Global Moderator
Posts: 3112
Joined: Sat Aug 05, 2006 9:38 am
Contact:

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by gmg » Wed Dec 22, 2010 3:45 pm

hyperion wrote:Gérard, please tell me what a mounted shared memory device is supposed to fix ?


I do not know why, exactly, but many distro use this, 'fedora' 'slackware' etc................... ;)

User avatar
Crocus
Community Packager
Community Packager
Posts: 264
Joined: Sat Mar 11, 2006 6:27 pm
Location: Craon - France (53)
Contact:

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by Crocus » Wed Dec 22, 2010 4:27 pm

hello, I confirm the franco's trash problem : files are deleted with any answer...

Crocus

User avatar
gmg
Global Moderator
Global Moderator
Posts: 3112
Joined: Sat Aug 05, 2006 9:38 am
Contact:

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by gmg » Wed Dec 22, 2010 4:39 pm

For JP,

http://www.jeyg.info/tmpfs-et-devshm/

i confirm, the stillborn, post, it seem that to be used by ati driver, and also, by many applications.

prfaasse
Zenwalk Packager
Zenwalk Packager
Posts: 1548
Joined: Fri Mar 10, 2006 9:09 am
Location: Amsterdam
Contact:

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by prfaasse » Wed Dec 22, 2010 7:38 pm

Install finished, plus upgraded the following packages, as pointed out in the previous posts of this thread:

gvfs-1.6.6-i486-70.1.txz
sysvinit-2.86-i486-70.1.txz
orage-4.7.5-i486-70.1.txz
zenwalk-desktop-6.9-noarch-70.1.txz
samba-3.5.6-i486-1.txz

So far, i've got a xfce-based 'ok' running machine, with only to report that the icon for

Applications->Office->Orage Globaltime

seems to be missing here.

Also, the <CTRL><ALT><F1 .. F4> text-mode consoles do not show up. Instead, the cursor of the Xorg desktop disappears (the rest of the screen is unchanged..), I *can* login (blindly..) to tty2, and the resulting user does show up in 'who', but no console ever becomes visible.
Update: I found the following in the dmesg output:

Code: Select all

[Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1" if the current driver doesn't work.
[drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0


I tried several permutations of the i915 module parameters in /etc/modprobe.d/i915-kms.conf attempting to get both Xorg to start and get the non-Xorg F2/F3 etc consoles operational, but so far no luck. I end up with either Xorg will not start because it has no kernel modesetting par, or no non-Xorg consoles.


edit:

Another thing: IceCat requests -upon each start- permission to install the 'GNU privacy extensions'; unfortunately i can not give a much better description :'( The popup window itself prevents me from getting an actual IceCat window. Only when i click either cancel or install does the IceCat itself show up.... Ok, after a vi session: here is the text of the popup window:

Code: Select all

Install software from authors whom you trust
GNU GNUzilla privacy extension (Author not verified)
file:///usr/lib/icecat/extensions/privacy_ext.xpi

|cancel|     |install now|


edit2:

brasero does not start:

Code: Select all

prf[~]$ brasero

GLib-GIO-ERROR **: Settings schema 'org.gnome.brasero.config' is not installed

aborting...
Aborted

User avatar
franco
Master Zenwalker
Master Zenwalker
Posts: 616
Joined: Fri Dec 28, 2007 2:36 pm
Contact:

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by franco » Thu Dec 23, 2010 9:31 am

No more problems whit Brasero.
Goobox does not detect my external CD. If I try to switch CD in preferences crash. The system detect and eject the CD(I do not use goobox. I install Asunder and Audacious) Is an old problem.
Whit the script in /etc/fstab seems that all the problems that follow me in snapshot are solved.
For wireless I'm still in the same problem.
I have to do what I already posted.


Compiling gthumb 2.12, during make I had this notification:
-------------------------------------------
/usr/include/linux/types.h:13:2: warning: #warning "Attempt to use kernel headers from user space, see http://kernelnewbies.org/KernelHeaders"
--------------------------------------------------------------------
Gthumb was installed.
---------------------------------
prfaaasse
for intel grphic run liloconfig
at boot parametres write i915.modeset=1
and choose normal vga console
for brasero=

viewtopic.php?f=2&t=29283&start=15

hyperion
This package fixes the glib-compile-schemas bug : http://download.zenwalk.org/people/jp/p ... 6-70.1.txz

prfaasse
Zenwalk Packager
Zenwalk Packager
Posts: 1548
Joined: Fri Mar 10, 2006 9:09 am
Location: Amsterdam
Contact:

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by prfaasse » Thu Dec 23, 2010 11:39 am

;D ;D Ah, the package does indeed address that brasero error, but: since i've installed it after getting zenwalk on-line, the postinstall was not re-run.... That's why on my system the error was still there...

Got video ok now... Note to self: do the same thing to my 'at work' D620 machine... One thing does make me wonder though: for the xf86-video-intel driver, i've added a file /etc/modprobe.d/i915-kms.conf which contains the text: "options i915 modeset=1". Why then do i still have to add a very similar line to lilo.conf?

Let's see if i can break anything else before sundown X!!

edit:

A minor 'thing': The icon in the panel (2-nd from the right) with the 'big battery' and the 'power cord' seems unsure about what size to assume: about each 2-nd boot it becomes 'big', the other times it is way smaller.

til

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by til » Thu Dec 23, 2010 3:48 pm

/usr/include/linux/types.h:13:2: warning: #warning "Attempt to use kernel headers from user space, see http://kernelnewbies.org/KernelHeaders"

In general, user space programs are built against the header files provided by the distribution, typically from a package named glibc-devel, glibc-kernheaders or linux-libc-dev. These header files are often from an older kernel version, and they cannot safely be replaced without rebuilding glibc as well. In particular, installing /usr/include/linux as a symbolic link to /usr/src/linux/include or /lib/modules/*/build/include/linux is highly discouraged as it frequently breaks rebuilding applications

I'm using the slackware kernel headers for a long time (they have been used when building glibc/gcc) and I was shocked by JP's decision to bundle both in his kernel package
- and relieved when he part them again!
The correct way to package the header files for a distribution is to run 'make headers_install' from the kernel source directory to install the headers into /usr/include and then rebuild the C library package, with a dependency on the specific version of the just installed kernel headers.

til

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by til » Thu Dec 23, 2010 8:55 pm

I've found a segfault in xfce4-panel, persistent in my logs since dec-11-2010
/var/log/messages:Dec 11 15:36:22 (none) kernel: xfce4-panel[6925]: segfault at 0 ip b6ed27f2 sp bf988a14 error 4 in libc-2.12.1.so[b6e57000+15b000]

User avatar
bipbip
Global Moderator
Global Moderator
Posts: 2348
Joined: Mon Apr 10, 2006 12:43 pm
Location: Ath (Belgium)
Contact:

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by bipbip » Thu Dec 23, 2010 9:51 pm

For brasero, launch this in a terminal in root mode :

Code: Select all

/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas


Bip

prfaasse
Zenwalk Packager
Zenwalk Packager
Posts: 1548
Joined: Fri Mar 10, 2006 9:09 am
Location: Amsterdam
Contact:

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by prfaasse » Fri Dec 24, 2010 1:09 am

Done ;D I realized that installing a new rc.postinstall would not be enough. You sould also *run* it, which does not usually happen once the system is fully installed and running, or else that "/usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas" does never get actually executed.. X!!

User avatar
franco
Master Zenwalker
Master Zenwalker
Posts: 616
Joined: Fri Dec 28, 2007 2:36 pm
Contact:

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by franco » Fri Dec 24, 2010 12:06 pm

I really don't know the cause of this strange behavior in wireless connection.
I just put down a theory.
Could be possible that, whit that optional in /etc/pam.d/system-auth
the system looks for the keyring manager and wicd stops working?
Does people who use gnome and network manager has ever come out whit this problem?
Anyway as I said, for the moment I just delete that line in pam.d and wicd.wireless-settings, reboot and configure again the connection.

User avatar
Hekko
Regular Zenwalker
Regular Zenwalker
Posts: 17
Joined: Fri Aug 15, 2008 10:34 pm
Location: Poland
Contact:

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by Hekko » Fri Dec 24, 2010 12:57 pm

- simple-scan has no icon under menu "Applications"-"Graphics"-"Simple Scan"
Regards :)
Hekko

website: http://hekko.eu
skype: hekko-eu
gg uin: 9302

User avatar
Crocus
Community Packager
Community Packager
Posts: 264
Joined: Sat Mar 11, 2006 6:27 pm
Location: Craon - France (53)
Contact:

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by Crocus » Fri Dec 24, 2010 1:53 pm

hello,

I have this message when I want to extract some tar.gz file (like this one for example) with file roller :

Code: Select all

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now


In a CLI, tar -xf file.tar.gz is working.

Crocus

User avatar
gmg
Global Moderator
Global Moderator
Posts: 3112
Joined: Sat Aug 05, 2006 9:38 am
Contact:

Re: Zenwalk 7.0 ALPHA ISO is available for testing !

Post by gmg » Fri Dec 24, 2010 2:10 pm

No problem with file-roller, here.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests