Re: Mplayer is in the snapshot

Official news from the Zenwalk crew
User avatar
hyperion
Administrator
Administrator
Posts: 2703
Joined: Fri Mar 10, 2006 8:52 am
Location: Nantes - France
Contact:

Mplayer is in the snapshot

Post by hyperion » Sat Dec 02, 2006 7:15 pm

Mplayer is in the snapshot repository :

Added [xap] mplayer-1.0rc1-i486-42.2.tgz (an atempt to replace xine/gxine, the prefered way to start playing a video should be to use audacious, this launching method add session support to mplayer, this was a feature awaited since a long time that mplayer doesn't provide yet by it's own, firefox plugin is included as well as win32 codecs, so there's an overlap with xine-lib)

Updated [xap] audacious-1.2.2-i486-42.4.tgz (added several plugins + mplayer support, meaning that audacious become a mplayer frontend, simpler, but in some sense superior to Gmplayer in term of session handling)

We need feedback :
- usability ?
- quality ?
- features ?
- look ?

Thanks

JP
A gentleman is someone who can code java, but doesn't..

arox1
Experienced Zenwalker
Experienced Zenwalker
Posts: 134
Joined: Mon Sep 11, 2006 6:41 pm
Location: Poland
Contact:

Re: Mplayer is in the snapshot

Post by arox1 » Sat Dec 02, 2006 7:17 pm

I'm still using mplayer pre8 because with rc1 I have problems with .ogm files but I'll try to test it

jjacobs2
Regular Zenwalker
Regular Zenwalker
Posts: 15
Joined: Tue Aug 22, 2006 4:30 am
Contact:

Re: Mplayer is in the snapshot

Post by jjacobs2 » Sat Dec 02, 2006 8:10 pm

I was impressed with how little CPU power the RC1 requires even compared to the old pre8.  I haven't tried the audacious frontend yet so I can't comment on that.  It's a shame Nvidia and ATI haven't bothered to put hardware decoding in their drivers yet.  That would help even older computers to play the new video formats.

User avatar
omns
Artwork Designer
Artwork Designer
Posts: 131
Joined: Fri Nov 10, 2006 11:48 pm
Location: non-local
Contact:

Re: Mplayer is in the snapshot

Post by omns » Sat Dec 02, 2006 9:10 pm

The Firefox plugin doesn't work at Apple Trailers. It downloads the movie but then can't play it.
My album at Zenwalk Artwork
do less - be more

mykey
Senior Zenwalker
Senior Zenwalker
Posts: 343
Joined: Sat Mar 11, 2006 4:58 pm
Location: blueplanet
Contact:

Re: Mplayer is in the snapshot

Post by mykey » Sat Dec 02, 2006 9:23 pm

I won't use it unless this version is compiled with xvid support - is it ?

User avatar
hyperion
Administrator
Administrator
Posts: 2703
Joined: Fri Mar 10, 2006 8:52 am
Location: Nantes - France
Contact:

Re: Mplayer is in the snapshot

Post by hyperion » Sat Dec 02, 2006 9:29 pm

it is, try it and let me know about any problem

JP
A gentleman is someone who can code java, but doesn't..

mykey
Senior Zenwalker
Senior Zenwalker
Posts: 343
Joined: Sat Mar 11, 2006 4:58 pm
Location: blueplanet
Contact:

Re: Mplayer is in the snapshot

Post by mykey » Sun Dec 03, 2006 10:04 am

I did not mean xvid for watching but for encoding  ;) - there is a package on slacky.it which can do that - needs some dependencies though .. as for all the rest your package looks fine  :)

User avatar
hyperion
Administrator
Administrator
Posts: 2703
Joined: Fri Mar 10, 2006 8:52 am
Location: Nantes - France
Contact:

Re: Mplayer is in the snapshot

Post by hyperion » Sun Dec 03, 2006 10:08 am

To save me time : give me additional configure flags, then I will add it to the next package :)

JP
A gentleman is someone who can code java, but doesn't..

fredg

Re: Mplayer is in the snapshot

Post by fredg » Sun Dec 03, 2006 10:44 am

@Mikey:
Do you talk about the xvidcore package ?
This package is in the "current-old" repo (it works under snapshot), so if Mplayer is like Avidemux, you have to install it to enable it.

++

mykey
Senior Zenwalker
Senior Zenwalker
Posts: 343
Joined: Sat Mar 11, 2006 4:58 pm
Location: blueplanet
Contact:

Re: Mplayer is in the snapshot

Post by mykey » Sun Dec 03, 2006 6:50 pm

I have xvidcore installed.

When I want to compile ogmrip it complains about mplayer not being compiled with support for xvid - I think the flag is --enable=xvid

semakwetu

Re: Mplayer is in the snapshot

Post by semakwetu » Sun Dec 03, 2006 7:40 pm

I'm impressed with Audacious' limited use of resources, mainly in its ability to continue to play shoutcast streamed media without loosing that connecting while I browse the internet.

I'm only possibly experiencing one problem which that I can open .ram media in gmplayer with no problem but gmplayer wont run the same file if I ask zenwalk to play it through Audacious.  I am guessing this is a problem with the mplayer plug-in and I need to report this the author.

Does anyone else have this problem?  Is it a known limitation of the plug-in?

Thanks,

User avatar
sweetnsourbkr
Senior Zenwalker
Senior Zenwalker
Posts: 347
Joined: Wed Oct 25, 2006 4:47 pm
Location: ever closer to bliss ....
Contact:

Re: Mplayer is in the snapshot

Post by sweetnsourbkr » Sun Dec 03, 2006 8:46 pm

I get a dependency error when running rc1.

mplayer: error while loading shared libraries: libmpcdec.so.3: cannot open shared object file: No such file or directory
ThinkZen member #000
Proud Thinkpad Zenwalker

User avatar
hyperion
Administrator
Administrator
Posts: 2703
Joined: Fri Mar 10, 2006 8:52 am
Location: Nantes - France
Contact:

Re: Mplayer is in the snapshot

Post by hyperion » Sun Dec 03, 2006 10:48 pm

Install audacious,

The dep file will be updated

Thanks

JP
A gentleman is someone who can code java, but doesn't..

BullGates
Experienced Zenwalker
Experienced Zenwalker
Posts: 126
Joined: Sat Mar 11, 2006 11:18 am
Contact:

Re: Mplayer is in the snapshot

Post by BullGates » Sat Dec 09, 2006 11:42 am

Hello,
I have some sound problems using mplayerplugin: if something is using sound mplayer can't play any sound. Sometimes I also have this problem with flash, and it affects mplayer as well. Shouldn't there be the config files of mplayer and mplayer plugin with esd or sdl as audio drivers?

oskar
Dev team
Dev team
Posts: 1347
Joined: Fri Mar 10, 2006 11:17 am
Contact:

Re: Mplayer is in the snapshot

Post by oskar » Sat Dec 09, 2006 1:07 pm

@mykey
mykey wrote:I won't use it unless this version is compiled with xvid support - is it ?


it would be helpful if you can give an argument why is xvidcore so important for encoding? I have encoded some stuff with mplayer to ogm(mpeg4/vorbis) and it always worked. Trying to code mplayer with xvidcore never worked properly. In the end xvid will only do mpeg4 and afaik its not faster nor better.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests