Zenwalk 7.9.1 is ready !!

Official news from the Zenwalk crew
User avatar
hyperion
Administrator
Administrator
Posts: 2694
Joined: Fri Mar 10, 2006 8:52 am
Location: Nantes - France
Contact:

Zenwalk 7.9.1 is ready !!

Post by hyperion » Thu Jun 19, 2014 7:54 pm

Hi,

An improved and up to date version of Zenwalk 64 : Zenwalk 7.9.1 is ready.

http://download.zenwalk.org/people/jp/7 ... -7.9.1.iso

One more step toward the 8.0.

It should be already stable enough for production, nearly finished.

Please report bugs :)

Have fun
JP

wang
Regular Zenwalker
Regular Zenwalker
Posts: 35
Joined: Sat Feb 22, 2014 7:27 pm
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by wang » Fri Jun 20, 2014 9:54 am

As I said it looks ok
This morning I install some extras, for a while everything works good then netpkg start not finding the deps. The system became increaseling slow. I have only 2 gb ram and my connection
is not great. The sensation is that is a lot slower then 7.9.
Yesterday I had that problem inserting usb sticks. gnome-player start loading all the files.
I will try to remove m-player and some other stuff to see if it is this running in the background the problem.

User avatar
hyperion
Administrator
Administrator
Posts: 2694
Joined: Fri Mar 10, 2006 8:52 am
Location: Nantes - France
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by hyperion » Fri Jun 20, 2014 10:12 am

then netpkg start not finding the deps


because no dep file in Slack repository.

I will have to implement some kind of local dep computation in netpkg ....

wang
Regular Zenwalker
Regular Zenwalker
Posts: 35
Joined: Sat Feb 22, 2014 7:27 pm
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by wang » Fri Jun 20, 2014 12:12 pm

/etc/rc.d/rc.M/line109/360 usr/bin/ionice: cannot execute binary file

I remove M-player and gnome-player and looks like a weight is gone.
I put Alien's vlc

without a good repository is very limited

User avatar
hyperion
Administrator
Administrator
Posts: 2694
Joined: Fri Mar 10, 2006 8:52 am
Location: Nantes - France
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by hyperion » Fri Jun 20, 2014 12:44 pm

without a good repository is very limited


What do you mean ?

Since all Slackware64 14.1 packages can be used on Zenwalk 8 : the choice of apps is really wide :)

JP

wang
Regular Zenwalker
Regular Zenwalker
Posts: 35
Joined: Sat Feb 22, 2014 7:27 pm
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by wang » Fri Jun 20, 2014 2:46 pm

If you mean to go around finding pkg I agree.
If you mean to run netpkg and find them no

User avatar
hyperion
Administrator
Administrator
Posts: 2694
Joined: Fri Mar 10, 2006 8:52 am
Location: Nantes - France
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by hyperion » Fri Jun 20, 2014 4:32 pm

Most Slackware official repositories work with netpkg, and most repos providing a PACKAGES.TXT file will also work.

For example, here's one that I use for Studio tools :
http://www.studioware.org/files/package ... re64-14.1/

User avatar
Blackbird
Experienced Zenwalker
Experienced Zenwalker
Posts: 181
Joined: Wed Jul 29, 2009 7:17 pm
Location: Netherlands
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by Blackbird » Sat Jun 21, 2014 7:17 am

I have a strange problem, during install the packages from the Z directory are not detected. In the menu I can see the list off all other directories, but there's no Z. This leaves me with a rather meagre Zenwalk....
Don't have this problem with 7.9. I use Unetbootin, never had any problems before. I've tried a few times, made a new usb on another computer with another downloaded ISO, but same result. And yes, I checked the md5sum.
I've been using Zenwalk-7.9 for a while now without any problems, quite satisfied.

Blackbird

User avatar
hyperion
Administrator
Administrator
Posts: 2694
Joined: Fri Mar 10, 2006 8:52 am
Location: Nantes - France
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by hyperion » Sat Jun 21, 2014 8:20 am

I have a strange problem, during install the packages from the Z directory are not detected


I did a 7.9.1 install here before uploading it, and no such problem.

I chose the "Full" install option, "Z" category was displayed.

please tell me the install steps / options you performed ?

User avatar
Blackbird
Experienced Zenwalker
Experienced Zenwalker
Posts: 181
Joined: Wed Jul 29, 2009 7:17 pm
Location: Netherlands
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by Blackbird » Sat Jun 21, 2014 9:10 am

please tell me the install steps / options you performed ?

Lets see, after the first steps of choosing partitions etc. I get a menu with a list of the directories available, like a, ap, l, x, xfce but no z. (with 7.9 z is there) All these are already marked, next step I choose full install and the installing starts. The second time around I kept my eyes on the screen, and indeed no packages from z were installed. To cut a long story short, I did exact the same as with the 7.9 version. I also made a new ISO with isomaster starting out with 7.9, adding al the updates and my own packages, and this does work. I've been trying to find the difference but don't know exactly where to look, didn't see anything obvious. When it's just me, just ignore this, must be one of my strange phenomena ???


Blackbird
edit: There is one other difference, with 7.9 the installation starts with showing the setup-menu, with 7.9.1 I am first asked to login as root and then type 'setup' before the menu turns up.

wang
Regular Zenwalker
Regular Zenwalker
Posts: 35
Joined: Sat Feb 22, 2014 7:27 pm
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by wang » Sun Jun 22, 2014 9:14 am

I use a DVD
What I find different was the boot pront
there are 3 options
1- UEFI-your cd
2- Your cd
3-detect boot any installed system

booting from 1 tells me this machine is using EFI/UEFI but not EFI system, go one telling me to exit setup and use cgdisk ecc.

booting from 2 is a normal slack-zenwalk installer, I use this one;no problem

booting from 3 fail, does not detect the file system, there was a zenwalk with xfs.

I try to update the old 4.9, there was only the kernels and the postinstall. I update only the kernels, run lilo and reboot.
I got a kernel panic. Then I use the cd to boot the system
huge.s root=/dev/sda1 rdinit= ro
that works so I run liloconfig and reboot, again kernel panic
Anyway I can always boot the system with the cd.
Also this system is in xfs.

As I said the only problem is this strange behavior of gnome-player
solved getting rid of him.

Yes you can add more slack repositories but the problem is that mostly of them are not updated at the same time. And the deps problem.
Is working but still not look like a system that you can send in the world.

User avatar
hyperion
Administrator
Administrator
Posts: 2694
Joined: Fri Mar 10, 2006 8:52 am
Location: Nantes - France
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by hyperion » Sun Jun 22, 2014 10:28 am

Is working but still not look like a system that you can send in the world.


At least : it's already 1000% more "sendable" to the world than the stock Slackware, considering the number of improvement and simplifications :)

JP

User avatar
Blackbird
Experienced Zenwalker
Experienced Zenwalker
Posts: 181
Joined: Wed Jul 29, 2009 7:17 pm
Location: Netherlands
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by Blackbird » Sun Jun 22, 2014 10:29 am

I've managed to install 7.9.1. I used the ISO from 7.9 and replaced the directories containing the packages. Here the packages from z do show up in the 'package series selection' menu. This is what I mean:
https://picasaweb.google.com/1093504211 ... directlink
I didn't see anything about uefi at boot, just which kernels, I choose default, then text about keymap, making partitions, login as root, type setup and the normal setup-menu shows up. But, as I said, I use an usb with unetbootin.
Haven't had time to do much testing, but so far so good. Didn't try gnome-player yet.
About the repositories, my opinion is it is better to have only a few packages that work, than some which might be outdated when you don't have enough packagers to keep them up-to-date. When it's not there, I google, find or compile and have fun (yes, sometimes a lot of deps are needed, that's the only downside). If it is there but not working it can be disappointing.
For now I am glad Zenwalk is alive!

Blackbird

User avatar
hyperion
Administrator
Administrator
Posts: 2694
Joined: Fri Mar 10, 2006 8:52 am
Location: Nantes - France
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by hyperion » Sun Jun 22, 2014 10:30 am

Is working but still not look like a system that you can send in the world.


You would get the same problems with Slackware ... + many other problems ...

At least : it's already 1000% more "sendable" to the world than the stock Slackware, considering the number of improvement and simplifications :)

but still not enough..................

JP

User avatar
Blackbird
Experienced Zenwalker
Experienced Zenwalker
Posts: 181
Joined: Wed Jul 29, 2009 7:17 pm
Location: Netherlands
Contact:

Re: Zenwalk 7.9.1 is ready !!

Post by Blackbird » Sun Jun 22, 2014 10:46 am

When ever is enough enough....
Don't know about my missing z directory, but I've been using 7.9 for a while now and am quite satisfied. It is impossible to meet everybody's needs, as long as the things that are there are working properly I think it's all right. The difficulty must be that different people have different problems, hard to put a finger on that.
Thanks for all your efforts,

Blackbird

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest